Windows not able to...
 
Notifications
Clear all

Windows not able to use all vCPUs

15 Posts
2 Users
0 Likes
1,138 Views
rj8899
(@rj8899)
Active Member
Topic starter
 

DigitalOcean droplet has 64GB RAM and 32 vCPUs. Installed windows' device manager shows all CPUs. But in Task Manager it is showing only 2. Is there a way to make it work. (Refer to the image attached.)

 
Posted : January 27, 2020 8:49 am
Topic Tags
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

DigitalOcean droplet has 64GB RAM and 32 vCPUs. Installed windows' device manager shows all CPUs. But in Task Manager it is showing only 2. Is there a way to make it work. (Refer to the image attached.)

Hello!

The task manager in Windows 10 defaults to "Overall utilization" as opposed to utilization per CPU core. You can change this behavior by opening the task manager, selecting "CPU" on the left side and then on the graph itself right-click.

Once you right-click, choose "Change graph to" and then choose "Logical processors".

Once changed you should see all of your CPU cores.

(Screenshot attached)

 
Posted : January 28, 2020 1:01 am
rj8899
(@rj8899)
Active Member
Topic starter
 

Hello,

Thank you for the quick response. I tried the solution provided by you. In fact, it still shows the same number of CPUs. I have attached screenshots of the local machine and DigitalOcean VM.

 
Posted : January 28, 2020 11:07 am
SysAdmin
(@sysadmin)
Reputable Member Admin
 

Hello,

Can you check msconfig to see if there is a limit of the number of CPU's?

msconfig --> Boot (Tab) --> Advanced Options (Button) --> Number of Processors (Is this checked?)

I also see you are running Windows 10 Pro, did you get that template from us?

 
Posted : January 28, 2020 8:46 pm
rj8899
(@rj8899)
Active Member
Topic starter
 

Hello,

'Number of processors' checkbox is unchecked. Also, the dropdown below it shows the max range of 2. 

I was trying some other tutorial. Those screenshots were taken on a different template than yours. But the results are same. 

The tutorial I was following.

 
Posted : January 29, 2020 3:39 pm
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

Hello,

'Number of processors' checkbox is unchecked. Also, the dropdown below it shows the max range of 2. 

I was trying some other tutorial. Those screenshots were taken on a different template than yours. But the results are same. 

The tutorial I was following.

Unfortunately that isn't our guide nor our templates, as such we really can't be of much assistance as to what may have gone wrong.

I would recommend contacting the author for assistance.

 
Posted : February 1, 2020 4:36 am
rj8899
(@rj8899)
Active Member
Topic starter
 

Hello, 

I still have a droplet with your template. Do you want me to send screenshots of that one? 

It has same problem. 

 

 
Posted : February 5, 2020 7:11 am
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

Hello, 

I still have a droplet with your template. Do you want me to send screenshots of that one? 

It has same problem. 

 

Sure, that would be great.

 
Posted : February 5, 2020 11:57 pm
rj8899
(@rj8899)
Active Member
Topic starter
 

Hello,

Check out the screenshots.

 
Posted : February 6, 2020 8:15 am
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

Hello,

Check out the screenshots.

Does the device manager show all of the CPU's?

 
Posted : February 6, 2020 6:46 pm
rj8899
(@rj8899)
Active Member
Topic starter
 

Yes, the Device manager shows all CPUs. 

 
Posted : February 7, 2020 5:48 am
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

Yes, the Device manager shows all CPUs. 

Honestly, I do not know why this may be happening.

Which Droplet do you have?

 
Posted : February 11, 2020 1:17 am
rj8899
(@rj8899)
Active Member
Topic starter
 

@sysadmin

Compute-optimized with 32 CPUs and 64GB RAM.

 

 
Posted : February 12, 2020 4:03 am
SysAdmin
(@sysadmin)
Reputable Member Admin
 
Posted by: @rj8899

@sysadmin

Compute-optimized with 32 CPUs and 64GB RAM.

 

Got it, thank you.

I will dig into it and will let you know what I find.

 
Posted : February 17, 2020 3:26 am
rj8899
(@rj8899)
Active Member
Topic starter
 

@sysadmin

Thank you so much. Eagerly waiting for a good outcome.

 

 
Posted : February 18, 2020 12:17 pm
Share: